Opkg fails to download packages and package information. What is wrong?

Since a while, running "opkg update" results in the following error messages:

Downloading http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/base/P...
Downloading http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/debug/...
Downloading http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/gstrea...
Downloading http://www.angstrom-distribution.org/feeds/2008/ipk/glibc//all/Packages.gz
Downloading http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/perl/P...
Downloading http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/python...
Downloading http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/machin...
Collected errors:
 * Failed to download http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/base/P.... 
error detail: HTTP response code said error
 * Failed to download http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/debug/.... 
error detail: HTTP response code said error
 * Failed to download http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/gstrea.... 
error detail: HTTP response code said error
 * Failed to download http://www.angstrom-distribution.org/feeds/2008/ipk/glibc//all/Packages.gz. 
error detail: HTTP response code said error
 * Failed to download http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/perl/P.... 
error detail: HTTP response code said error
 * Failed to download http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/python.... 
error detail: HTTP response code said error
 * Failed to download http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv5te/machin.... 
error detail: HTTP response code said error

The problem here is that the default rootfs of the Stamp9G20 and PortuxG20 was the Ångström Distribution 2008 for a long time but this version is discontinued so all packages have been removed from the servers. Since Apr 19, 2012, both products will be delivered with version 2011.03.

Possible Solutions:

  • The best solution is to use the updated rootfs image provided in the download section which uses Ångström 2011.03. If you do not want to start from scratch, the other two options are also possible but are risky or inconvenient.
  • Replace the 2008 with 2011.03 in all config files in /etc/opkg and upgrade to this newer version (opkg update and opkg upgrade). Be aware that this is unsafe and can result in a completely unusable system as opkg is not prepared for such major updates.
  • Cherry pick packages from http://www.angstrom-distribution.org/feeds/2011.03 and install the manually (you have to resolve dependencies yourself). Either use wget to download and then install with opkg or give the direct URL to opkg. Using wget has the advantage, that you do not have to redownload a file if opkg notices missing dependencies. This option is much safer than the previous because you have complete control over what is installed and in which order.

Re: Opkg fails to download packages and package information. ...

oops...

Does this mean I am unable to install any packages without upgrading (how??) all of my stamp9g20s???
To be honest, this does not sound very appealing to me!

Re: Opkg fails to download packages and package information. ...

oops...

Does this mean I am unable to install any packages without upgrading (how??) all of my stamp9g20s???
To be honest, this does not sound very appealing to me!

Syndicate content